Vive FG! (Foro) Vive FG! (Foro)
Foro de la comunidad hispana oficial del simulador de código abierto FlightGear Flight Simulator.






Corregir mal sonido en Ubuntu 9.10

 
Publicar nuevo tema   Responder al tema    Foros de discusión
Ver tema anterior :: Ver tema siguiente  
akoharowen
Pasajero



Registrado: 15 Nov 2009
Mensajes: 25




 MensajePublicado: Mar Dic 22, 2009 5:55 am    Asunto: Corregir mal sonido en Ubuntu 9.10 Responder citando Back to top

Cada vez que ejecutaba el FG en Ubuntu tenía un desagradable problema con el sonido (Una especie de Crunch, distorsión o algo parecido) Lo solucioné editando (si no existen hay que crearlos) estos dos archivos:

En .openalrc agregué:
(define devices '(alsa))
(define alsa-device "pulse")

En .alsoftrc
drivers = alsa

¡Espero que les sea de utilidad!
Saludos!

_________________
Yo uso Protocolos Libres para Comunicarme. Si querés hablar conmigo hacelo mediante Jabber a: akoharowen@jabber.org
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
El Flauta
Ataúd Volante

Ataúd Volante


Registrado: 29 Mar 2008
Mensajes: 3975
Ubicación: SCVM, Chile



 MensajePublicado: Mar Dic 22, 2009 8:55 am    Asunto: Responder citando Back to top

Ah... excelente. Yo siempre pensé que dicho problema era por lo exótico de mi tarjeta de sonido (y su casi nulo soporte en Linux) Smile Apenas lo pruebe te digo cómo me fue.

_________________


No respondo consultas por privado, ojo
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
akoharowen
Pasajero



Registrado: 15 Nov 2009
Mensajes: 25




 MensajePublicado: Mar Feb 02, 2010 2:42 am    Asunto: Responder citando Back to top

Fe de erratas: La solución que planteé en un primer momento no funcionaba muy bien debido a un cambio en la sintaxis de los ficheros de configuración de OpenAL (El servidor de sonido).
Lo que hay que hacer es esto:

1) En un terminal escribir sudo gedit /etc/openal/alsoft.conf
2) Buscar las siguientes lineas y dejarlas tal cual siguen:

## ALSA backend stuff
##
[alsa]

## device:
# Sets the device name for the default playback device.
device = alsa


Nótese que saqué el # de device

A mi me funcionó y también destrabó el problema con otros juegos que depende de OpenAL como por ejemplo Glest.

Saludos!

_________________
Yo uso Protocolos Libres para Comunicarme. Si querés hablar conmigo hacelo mediante Jabber a: akoharowen@jabber.org
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
Mostrar mensajes de anteriores:   
Publicar nuevo tema   Responder al tema    Foros de discusión -> Paraíso Linux Todas las horas son GMT + 1 Hora
Página 1 de 1


 
Cambiar a:  
Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro


Crear foro phpbb | foros de Videoconsolas | Hosting gratis | soporte foros | Contactar | Denunciar un abuso | FAQ | Foro ejemplo

Para hosting especialidado en foros phpbb ssd en Desafiohosting.com