Vive FG! (Foro) Vive FG! (Foro)
Foro de la comunidad hispana oficial del simulador de código abierto FlightGear Flight Simulator.






FlightGear en ubuntu

 
Publicar nuevo tema   Responder al tema    Foros de discusión
Ver tema anterior :: Ver tema siguiente  
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Dom Sep 23, 2012 5:05 am    Asunto: FlightGear en ubuntu Responder citando Back to top

Si quieren usar flightgear en ubuntu verán que la versión de los repositorios oficiales es la 2.4; para usar la 2.8 pueden usar los repositorios extraoficiales de playdeb.
http://www.playdeb.net/software/FlightGear
Como figura en las instrucciones de la página es para usarlo con el click en el navegador,
http://www.playdeb.net/updates/Ubuntu/12.04#how_to_install
pero basandonos en eso haremos lo siguiente (a la debian):

1. Con nuestro editor de textos (gedit, nano, kate, etc) agregaremos el repositorio de playdeb a el listado de repositorios de software que usa ubuntu

Cita:
sudo gedit /etc/apt/sources.list


y colocaremos el repositorio al final del archivo

Código:
deb http://archive.getdeb.net/ubuntu precise-getdeb games


2. Paso opcional, agregar la firma de los paquetes para que apt no se queje de que son paquetes sin firmar.

Cita:
wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -


3. Actualizamos nuestro archivo con la lista de paquetes

Cita:
sudo apt-get update


4. Instalamos flightgear desde playdeb e instalará la versión 2.8

Cita:
sudo apt-get install flightgear

Razón para editar: generalizar título



Ultima edición por sa7k el Mie Feb 20, 2013 12:38 pm, editado 1 vez
 
Ver perfil de usuario Enviar mensaje privado
NiTuS
Administrador



Registrado: 01 Jun 2007
Mensajes: 2259
Ubicación: Reus, España (LERS)



 MensajePublicado: Dom Sep 23, 2012 12:30 pm    Asunto: Responder citando Back to top

¿Es físicamente posible instalar FlightGear 2.8.0 en Kubuntu 10.10? Lo digo porque lo he intentado con algunos repositorios (además de getdeb.net) y tengo problemas con las dependencias:

Els següents paquets tenen dependències sense satisfer:
libglib2.0-0 : Trenca: gvfs (< 1.8) però s'instal·larà 1.6.4-0ubuntu1.1
libpango1.0-0 : Trenca: plymouth (< 0.8.2-2ubuntu19) però s'instal·larà 0.8.2-2ubuntu5
E: Paquets trencats


Es decir, parece ser que me está indicando que tengo que actualizar el sistema operativo entero, cosa que no quiero hacer. Confused

_________________
 
Ver perfil de usuario Enviar mensaje privado Enviar email Visitar sitio web del autor
ludomo
Co-piloto



Registrado: 19 Sep 2012
Mensajes: 429
Ubicación: Reus - LERS



 MensajePublicado: Dom Sep 23, 2012 1:04 pm    Asunto: Responder citando Back to top

NiTuS, podrías compilar tú mismo la versión 2.8 y así personalizarla a lo que tengas en tu sistema. Pero la cantidad de librerías extra y modernizadas que necesitarás probablemente conviertan la tarea en algo más costoso en tiempo y esfuerzo que simplemente actualizar el sistema operativo completo.

_________________
Callsign: EC-ICE
 
Ver perfil de usuario Enviar mensaje privado
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Dom Sep 23, 2012 3:17 pm    Asunto: Responder citando Back to top

Es como dice ludomo, lo mejor sería compilarlo, separando de la instalación principal y con las dependencias necesarias que no estén disponibles en la instalación de 10.10 que también deberás compilar.

_________________
Volando desde SA7K - Matrícula LV-EPM
 
Ver perfil de usuario Enviar mensaje privado
dmt-bcn
Pasajero



Registrado: 26 Sep 2012
Mensajes: 4




 MensajePublicado: Sab Sep 29, 2012 2:21 am    Asunto: Responder citando Back to top

A mi el 4 paso no me dejaba hacerlo, pero gracias a los otros que diste, me salio la version 2.8 en synaptic, estoy muy verde en linux, aun estoy con la mente en windows jejeje mil gracias
 
Ver perfil de usuario Enviar mensaje privado
El Flauta
Ataúd Volante

Ataúd Volante


Registrado: 29 Mar 2008
Mensajes: 3975
Ubicación: SCVM, Chile



 MensajePublicado: Sab Sep 29, 2012 12:27 pm    Asunto: Responder citando Back to top

Compilar = tedio

Los paquetes deb son lo mejor que hay Smile

Aunque por mi parte ya casi no utilizo Linux... aparte del nulo soporte a mi equipamiento de audio, finalmente prefiero utilizar más mi tiempo en hacer cosas prácticas (como mi trabajo) que en configurar mi sistema Confused

_________________


No respondo consultas por privado, ojo
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Mie Feb 20, 2013 12:46 pm    Asunto: PPA para Oneiric (11.10) y posteriores. Responder citando Back to top

Una nueva opción para los usuarios de ubuntu. Aunque por suerte estos días revivió playdeb.
Un usuario hizo un ppa que es como un repositorio privado experimental que es bastante popular en el mundo de ubuntu.
Si quieren probarlo acuerdense que no es software tan confiable como el oficial pero parece que se fueron arreglando algunas fallas que había.
Lo que tienen que hacer según el autor de los paquetes es:
Código:
sudo add-apt-repository ppa:saiarcot895/flightgear
sudo apt-get update
sudo apt-get install flightgear

No lo he probado pero según dicen en el foro en inglés ya funciona correctamente.
 
Ver perfil de usuario Enviar mensaje privado
Mostrar mensajes de anteriores:   
Publicar nuevo tema   Responder al tema    Foros de discusión -> Paraíso Linux Todas las horas son GMT + 1 Hora
Página 1 de 1


 
Cambiar a:  
Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro


Foro gratis | foros de Videoconsolas | Hosting gratis | soporte foros | Contactar | Denunciar un abuso | FAQ | Foro ejemplo

Para vps para prestashop ssd en Desafiohosting.com