Vive FG! (Foro) Vive FG! (Foro)
Foro de la comunidad hispana oficial del simulador de código abierto FlightGear Flight Simulator.






Instalando FlightGear 2.0 en ubuntu 9.10 Karmik.

 
Publicar nuevo tema   Responder al tema    Foros de discusión
Ver tema anterior :: Ver tema siguiente  
Torghest
Auxiliar de vuelo



Registrado: 17 Ago 2010
Mensajes: 52
Ubicación: Periodo Jurasico



 MensajePublicado: Lun Ago 23, 2010 11:08 pm    Asunto: Instalando FlightGear 2.0 en ubuntu 9.10 Karmik. Responder citando Back to top

Hola muy buenas noches, bueno he pensado que debia de habrir este post para que si alguien conoce o ha instalado la version 2.0 de Flightgear que lo posteara a continuacion.

Yo personalmente despues de buscar en google he encontrado este apartado de la pagina de flightgear en donde esta la version 2.0.

http://packages.flightgear.org.uk/slackware-11.0/

Desde ahi tenemos la version 2.0, creo que es el enlace 2, donde pone Data.

Pero una vez bajado no se seguir, recuerdo que me faltaban cosas por instalar para que el ./configure funcionara.

Os lo ruego a vosotros que sabeis mucho mas que yo del tema, que pongais una especie de guia.

Muchas gracias de nuevo y perdonadme la molestia.

Un saludo!.

 
Ver perfil de usuario Enviar mensaje privado
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Mar Ago 24, 2010 12:56 am    Asunto: Responder citando Back to top

b., no te valen, porque no son paquetes debian. Slackware es otra distribución, redhat otra, suse otra, debian otra, cada una con su manera de hacer las cosas diferentes. Ubuntu está baado en debian, debes buscar paquetes .deb. :\ hay que mirarse las respuestas, porque ya dejé la ruta directa a los paquetes rusos. Se intalan gráficamente con gdebi, pero en consola es aún más sencillo: te vas a donde los hayas descargado y ejecutas un simple comando
Código:
# sudo dpkg -i NOMBREPAQUETE.deb
Si el nombre del paquete es muy complicado entonces ejecutas "ls *.deb" y si ves tan sólo los dos que necesitas, entonces puedes cambiar nombre del paquete con el asterisco. Saludos cordiales
 
Ver perfil de usuario Enviar mensaje privado
Torghest
Auxiliar de vuelo



Registrado: 17 Ago 2010
Mensajes: 52
Ubicación: Periodo Jurasico



 MensajePublicado: Mar Ago 24, 2010 12:50 pm    Asunto: Re: Responder citando Back to top

almursi escribió:
Busca estos dos paquetes (ahora mismo no recuerdo de qué página me los bajé).

Edito: Quizá también necesites:
simgear_2.0.0-1_i386.deb

Pero este no llegué a localizarlo (hace unos meses) y tuve que compilarlo.

Edito2: http://www.flightgear.ru
(Me sonaba que había sido cosa de los tobarich Very Happy).

Esta es la línea de dependencias en flightgear_2.0.0-1_i386.deb:

Depends: freeglut3, libalut0 (>= 1.1.0-1), libc6 (>= 2.4), libdbus-1-3 (>= 1.0.2), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libhal1 (>= 0.5.8.1), libice6 (>= 1:1.0.0), libjpeg62, libopenal1, libopenscenegraph56 (>= 2.8.1), libopenthreads12 (>= 2.8.1), libplib1 (>= 1.8.5-1), libsm6, libstdc++6 (>= 4.4.0), libx11-6, libxext6, libxi6, libxmu6, libxt6, zlib1g (>= 1:1.1.4), flightgear-data (>= 2.0.0)

Parece que no necesita simgear 2.0 para instalarse, pero sí para compilar el código fuente.

Saludos cordiales.


Si, lo recuerdo, es eso, pero el simgear_2.0.0-1_i386.deb no lo he encontrado en ningun sitio, de momento tengo el fg-dev-bin-2010-08-02.tar.bz2 y el fg-dev-base-2010-08-02.tar.bz2 y otra que es el FlightGear-data-2.0.0-noarch-1.tgz (este ultimo bajado de la web que puse arriba que segun tu no me vale, digo segun tu porque yo no lo he provado aun).

De todas formas en la web oficial o esta muy escondido la version 2.0 para linux o simplemente no esta Sad

Por cierto en la web rusa no hay paquetes.deb al menos no los he visto...pero cualquiera se aclara ahi jeje.

Salud y buenos alimentos .
 
Ver perfil de usuario Enviar mensaje privado
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Mar Ago 24, 2010 9:09 pm    Asunto: Re: Responder citando Back to top

Torghest escribió:
De todas formas en la web oficial o esta muy escondido la version 2.0 para linux o simplemente no esta Sad

Por cierto en la web rusa no hay paquetes.deb al menos no los he visto...pero cualquiera se aclara ahi jeje.

Salud y buenos alimentos .


b., me refiero a esto:

almursi escribió:

http://digiwhite.flightgear.ru/flightgear-2.0/all/flightgear-data_2.0.0-1_all.deb
http://digiwhite.flightgear.ru/flightgear-2.0/i386/flightgear_2.0.0-1_i386.deb


De mi respuesta http://flightgear.creatuforo.com/-temas11899.html#11899

Instalando esos dos paquetes tienes la versión 2 del simulador sin necesidad de instalar nada adicional ni de desinstalar nada. El SimGear 2 tan sólo lo necesitas en caso de que te bajes el código para compilar. Saludos cordiales.
 
Ver perfil de usuario Enviar mensaje privado
Torghest
Auxiliar de vuelo



Registrado: 17 Ago 2010
Mensajes: 52
Ubicación: Periodo Jurasico



 MensajePublicado: Mie Ago 25, 2010 1:16 pm    Asunto: Responder citando Back to top

Ah vale, perdon Sad, bueno ya lo tengo instalado , pero tenia la version 9.1 instalada y me ha desaparecido del menu juegos.

Entonces, ahora mi unica duda y con esto ya termino jeje, es que si ejecuto fgfs blablabla me arranca el flightgear pero no se si me arranca el 9.1 o el 2.0 ><, hay alguna manera de diferenciarlos? lo pregunto porque cuando lo arranco asi:

fgfs --aircraft=f-14b --airport=LEVC --runway=12 --timeofday=afternoon --enable-real-weather-fetch

No se si estoy con el 9.1 o el 2.0.

Muchas gracias a tod@s!!.
 
Ver perfil de usuario Enviar mensaje privado
El Flauta
Ataúd Volante

Ataúd Volante


Registrado: 29 Mar 2008
Mensajes: 3975
Ubicación: SCVM, Chile



 MensajePublicado: Mie Ago 25, 2010 1:50 pm    Asunto: Responder citando Back to top

La forma más sencilla -pero menos técnica- es ver en el menú "View" las "Render options". Entre ambas versiones la diferencia de opciones es grande (Con la GIT ya es casi abismal, jaja).

En las versiones 2+, en ese menú aparecerán los nuevos shaders como "Landmass", "Snow", "Water reflections", que antes no existían.

Saludos

_________________


No respondo consultas por privado, ojo
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
Torghest
Auxiliar de vuelo



Registrado: 17 Ago 2010
Mensajes: 52
Ubicación: Periodo Jurasico



 MensajePublicado: Mie Ago 25, 2010 5:16 pm    Asunto: Responder citando Back to top

Hola Flauta, vale si me salen esas opciones, menos la de snow que no la he visto en rendering options.

Bueno supongo que ya esta todo, ahora solo me falta ver en que carpeta esta el flightgear2.0 ya que el urs/share/games no la he visto.

Y taaambien supongo que los aviones de la web oficial me iran ya todos sin problemas jeje.

Otra cosa, puedo borrar el flightgear 1.9 ?.

Saludos!.
 
Ver perfil de usuario Enviar mensaje privado
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Mie Ago 25, 2010 8:49 pm    Asunto: Re: Responder citando Back to top

Torghest escribió:
Hola Flauta, vale si me salen esas opciones, menos la de snow que no la he visto en rendering options.

Bueno supongo que ya esta todo, ahora solo me falta ver en que carpeta esta el flightgear2.0 ya que el urs/share/games no la he visto.

Y taaambien supongo que los aviones de la web oficial me iran ya todos sin problemas jeje.

Otra cosa, puedo borrar el flightgear 1.9 ?.

Saludos!.


b., mejor no, porque se pisan algunos archivos comunes (y seguramente ya no puedas arrancar ninguno). El paquete ruso es simplemente una facilidad para instalar la versión 2.0 con sencillez.

Seguramente tengas los dos, tan sólo están en rutas diferentes. El binario ejecutable de 1.9.1 lo tienes en /usr/games/fgfs, y el 2.0 de ese paquete creo recordar que en /usr/bin/fgfs. Si lo tratas de ejecutar con la ruta lo podrás ver, porque además sólo podrás ejecutar uno de ellos: usan una variable del sistema para determinar dónde están los archivos de datos del juego, y supongo que el paquete 2.0 lo habrá cambiado para apuntar a sí mismo. Si quieres arrancar -en ubuntu- el 1.9.1 tendrás que ejecutar esto:

Código:
# /usr/games/fgfs --fg-root=/usr/share/games/FlightGear

Más las opciones que quieras. Y si quieres que siempre se arranque con las mismas opciones (tanto en una como en otra versión, porque usan el mismo archivo) entonces edita (o crea) .fgfsrc que lo tienes (o debes tener) en tu /home/tumismo/.fgfsrc

Allí puedes incluir todas las opciones que quieras (compatibles con la línea de comandos, que sacas con fgfs --help), y ahorrarte el tener que escribirlas cada vez:

Código:
# opciones en .fgfsrc
--aircraft=f-14b
--airport=LEVC
--runway=12
--timeofday=afternoon
--enable-real-weather-fetch


Con el FGRun (caso de que puedas instalarlo desde algún repositorio) editas todas las opciones posibles del .fgfsrc pero de forma gráfica, que siempre será más cómodo para los que no estén familiarizados con linux y su línea de comandos.

Por otro lado, a la hora de instalar aviones o escenarios, ten en cuenta que tienes dos carpetas diferentes, y que los que instales en una no lo verás en la otra: lo que haya en /usr/share/games/FlightGear tan sólo los verás con el 1.9.1. (la del 2.0 búscala, creo que la verás en /usr/share/FlightGear).

Saludos cordiales.
 
Ver perfil de usuario Enviar mensaje privado
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Jue Ago 26, 2010 12:20 am    Asunto: Responder citando Back to top

b., por cierto, los .deb me los bajé en junio, puede que los hayan cambiado y que ahora sí desinstalen la versión 1.9.1 (si dices que no ves nada en /usr/share/games). La confirmación la podrías tener a través del synaptiic, sacando las propiedades del paquete y mirando si señala alguna incompatibilidad (la de junio no señalaba ninguna). Saludos cordiales.
 
Ver perfil de usuario Enviar mensaje privado
Torghest
Auxiliar de vuelo



Registrado: 17 Ago 2010
Mensajes: 52
Ubicación: Periodo Jurasico



 MensajePublicado: Vie Sep 03, 2010 10:17 pm    Asunto: Responder citando Back to top

Hola buenas a todos, nada ya esta, borre totalmente el 1.9 y ya tengo el 2.0 funcionando perfectamente con joystick hotas y todo ^^, gracias a todos por la mega ayuda Smile

Una cosa mas, no consigo encontrar la carpeta del flightgear 2.0, en usr/bin no esta Sad y en share/games tampoco, y tengo aqui 300 cosas para meterle pero como no lo encuentro Sad

saludos people".
 
Ver perfil de usuario Enviar mensaje privado
Torghest
Auxiliar de vuelo



Registrado: 17 Ago 2010
Mensajes: 52
Ubicación: Periodo Jurasico



 MensajePublicado: Vie Sep 03, 2010 10:19 pm    Asunto: Responder citando Back to top

Vale ya esta, esta en /USR/SHARE/FLIGHTGEAR/DATA ^^
Saludos.
 
Ver perfil de usuario Enviar mensaje privado
NiTuS
Administrador



Registrado: 01 Jun 2007
Mensajes: 2259
Ubicación: Reus, España (LERS)



 MensajePublicado: Lun Oct 04, 2010 11:04 pm    Asunto: Responder citando Back to top

:O ¡Intentaré instalar FG 2.0 en cuanto saquen la nueva versión de Ubuntu/Kubuntu, dentro de 5 días (10.10: 10/10/10)!

_________________
 
Ver perfil de usuario Enviar mensaje privado Enviar email Visitar sitio web del autor
Mostrar mensajes de anteriores:   
Publicar nuevo tema   Responder al tema    Foros de discusión -> Paraíso Linux Todas las horas son GMT + 1 Hora
Página 1 de 1


 
Cambiar a:  
Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro


Crear un foro | foros de Videoconsolas | Hosting gratis | soporte foros | Contactar | Denunciar un abuso | FAQ | Foro ejemplo

Para vps para prestashop ssd en Desafiohosting.com