Vive FG! (Foro) Vive FG! (Foro)
Foro de la comunidad hispana oficial del simulador de código abierto FlightGear Flight Simulator.






problemas para ejecutar en archlinux

 
Publicar nuevo tema   Responder al tema    Foros de discusión
Ver tema anterior :: Ver tema siguiente  
aald666
Pasajero



Registrado: 06 Mar 2012
Mensajes: 5




 MensajePublicado: Mar Mar 06, 2012 7:23 am    Asunto: problemas para ejecutar en archlinux Responder citando Back to top

tengo instalada la ultima versión de flightgear, pero resulta que desde la versión anterior nunca lo he podido ejecutar bien, ya que el sistema siempre se queda bloqueado cargando la ventana del programa, cosa que o me pasaba con ubuntu, pero en archlinux me pasa esto, ¿que sera?.

 
Ver perfil de usuario Enviar mensaje privado
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Mar Mar 06, 2012 7:57 pm    Asunto: Responder citando Back to top

Deberías probar ejecutar desde consola y mostrar el texto que sale cuando se cuelga. De paso escribí que placa de video tenés y qué driver usás. Así sin ningún dato es difícil que alguien te pueda ayudar.

_________________
Volando desde SA7K - Matrícula LV-EPM
 
Ver perfil de usuario Enviar mensaje privado
aald666
Pasajero



Registrado: 06 Mar 2012
Mensajes: 5




 MensajePublicado: Mar Mar 06, 2012 9:21 pm    Asunto: Responder citando Back to top

sa7k escribió:
Deberías probar ejecutar desde consola y mostrar el texto que sale cuando se cuelga. De paso escribí que placa de video tenés y qué driver usás. Así sin ningún dato es difícil que alguien te pueda ayudar.

fgfs --fg-root=/usr/share/FlightGear
***
***
*** Warning: changing bad FG_ROOT/--fg-root to '/usr/share/flightgear/data'
***
***
KI266 dme indicator #0 initialized
loading scenario 'nimitz_demo'
PNG lib warning : Malformed iTXt chunk
creating 3D noise texture... DONE
PNG lib warning : Interlace handling should be turned on when using png_read_image
PNG lib warning : Interlace handling should be turned on when using png_read_image
weather util initialized ...
Scaling image '/usr/share/flightgear/data/Textures.high/Signs/black.png' from (4096,128) to (2048,128)
Scaling image '/usr/share/flightgear/data/Textures.high/Signs/red.png' from (4096,128) to (2048,128)
Scaling image '/usr/share/flightgear/data/Textures.high/Signs/framed.png' from (4096,128) to (2048,128)
Scaling image '/usr/share/flightgear/data/Textures.high/Signs/yellow.png' from (4096,128) to (2048,128)
Initializing Nasal Electrical System
glLinkProgram "" FAILED
Program "" infolog:
error: shader uses too many varying components (40 > 32)

FRAGMENT glCompileShader "" FAILED
FRAGMENT Shader "" infolog:
0:9(12): warning: extension `GL_ATI_shader_texture_lod' unsupported in fragment shader
0:10(12): warning: extension `GL_ARB_shader_texture_lod' unsupported in fragment shader
0:0(0): error: no matching function for call to `texture2DLod(sampler2D, vec2, float)'
0:63(41): error: type mismatch
0:0(0): error: no matching function for call to `texture2DLod(sampler2D, vec2, float)'
0:113(47): error: type mismatch
0:0(0): error: no matching function for call to `texture2DLod(sampler2D, vec2, float)'
0:114(47): error: type mismatch

glLinkProgram "" FAILED
Program "" infolog:
error: linking with uncompiled shader
glLinkProgram "" FAILED
Program "" infolog:
error: shader uses too many varying components (36 > 32)

Scaling image '/usr/share/flightgear/data/Aircraft/c172p/Models/Liveries/fuselage-normal.png' from (4096,4096) to (2048,2048)
Scaling image '/usr/share/flightgear/data/Aircraft/c172p/Models/Liveries/wing-normal.png' from (4096,4096) to (2048,2048)
power up
 
Ver perfil de usuario Enviar mensaje privado
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Mie Mar 07, 2012 4:14 pm    Asunto: Responder citando Back to top

La placa de video es una ati? Qué driver estás usando?

_________________
Volando desde SA7K - Matrícula LV-EPM
 
Ver perfil de usuario Enviar mensaje privado
aald666
Pasajero



Registrado: 06 Mar 2012
Mensajes: 5




 MensajePublicado: Mie Mar 07, 2012 4:56 pm    Asunto: Responder citando Back to top

uso intel
xf86-video-intel
 
Ver perfil de usuario Enviar mensaje privado
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Mie Mar 07, 2012 5:24 pm    Asunto: Responder citando Back to top

Uh, estás jodido. Ningún intel tiene buen soporte para opengl. En ubuntu era usable con esa misma pc?

_________________
Volando desde SA7K - Matrícula LV-EPM
 
Ver perfil de usuario Enviar mensaje privado
aald666
Pasajero



Registrado: 06 Mar 2012
Mensajes: 5




 MensajePublicado: Jue Mar 08, 2012 5:10 am    Asunto: Responder citando Back to top

debe ser otra cosa, en windows me funcionaba a la perfeccion, en ubuntu tambien me funcionaba bien, en archlinux es que me pasa esto.
 
Ver perfil de usuario Enviar mensaje privado
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Jue Mar 08, 2012 9:58 am    Asunto: Responder citando Back to top

Si, andar tiene que andar, sólo que no como para que sea correctamente usable el simulador. No conozco bien archlinux. ¿Compilaste vos la versión que usás? Podrías probar compilar la versión de git.

_________________
Volando desde SA7K - Matrícula LV-EPM
 
Ver perfil de usuario Enviar mensaje privado
aald666
Pasajero



Registrado: 06 Mar 2012
Mensajes: 5




 MensajePublicado: Jue Mar 08, 2012 5:04 pm    Asunto: Responder citando Back to top

ya lo he reinstalado varias veces y no soluciona nada y la versión de git tampoco funciona.
 
Ver perfil de usuario Enviar mensaje privado
sa7k
Co-piloto



Registrado: 29 Ene 2012
Mensajes: 408
Ubicación: SA7K, Alto Paraná



 MensajePublicado: Jue Mar 08, 2012 6:06 pm    Asunto: Responder citando Back to top

Reinstalar es hacer lo mismo muchas veces, no debería solucionar nada.
Yo sospecharía de los drivers de video pero como no decís que placa es y no sé como es archlinux no puedo decir nada.
Quizás tengas mejor suerte preguntando en un foro de arch. Suerte.
 
Ver perfil de usuario Enviar mensaje privado
Mostrar mensajes de anteriores:   
Publicar nuevo tema   Responder al tema    Foros de discusión -> Paraíso Linux Todas las horas son GMT + 1 Hora
Página 1 de 1


 
Cambiar a:  
Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro


Crear foro gratis | foros de Videoconsolas | Hosting gratis | soporte foros | Contactar | Denunciar un abuso | FAQ | Foro ejemplo

Para vps hosting especialidado en foros phpbb ssd en Desafiohosting.com