Vive FG! (Foro) Vive FG! (Foro)
Foro de la comunidad hispana oficial del simulador de código abierto FlightGear Flight Simulator.






Señales horizontales en aeropuertos

 
Publicar nuevo tema   Responder al tema    Foros de discusión
Ver tema anterior :: Ver tema siguiente  
codolar
Sobrecargo



Registrado: 06 Jul 2009
Mensajes: 259
Ubicación: Menorca LEMH - España



 MensajePublicado: Dom Nov 01, 2009 4:46 pm    Asunto: Señales horizontales en aeropuertos Responder citando Back to top

Hola que tal?

Hace tiempo que intento colocar señales sobre los taxiways y RWY en varios aeropuertos, pero he desistido porque una vez ubicados cuando testeo se produce un "salto" y/o "bote" del avion al pasar sobre ellos. Wall
El otro dia encontre en la wiki de FG.org un Tutorial sobre ello:
"Blender Ground Signs Tutorial"
y vi esto:


me refiero a las señales sobre limites de RWY. Si alguien sabe como colocarlas sin "efectos secundarios" y quiere compartir su sabiduria, Rolling Eyes quedaria agredecido.

Saludos ¡Más cerveza doble!

 
Ver perfil de usuario Enviar mensaje privado Enviar email
El Flauta
Ataúd Volante

Ataúd Volante


Registrado: 29 Mar 2008
Mensajes: 3975
Ubicación: SCVM, Chile



 MensajePublicado: Dom Nov 01, 2009 5:27 pm    Asunto: Responder citando Back to top

Bueno... en dicho tutorial se supone que se explica en detalle todo lo relativo a hacer dichas señales sin tales "efectos secundarios" incluyendo hasta XML, ¿no? Rolling Eyes

_________________


No respondo consultas por privado, ojo
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
MacDrummer
Co-piloto



Registrado: 17 Sep 2009
Mensajes: 401
Ubicación: (SCEL) Chile



 MensajePublicado: Dom Nov 01, 2009 8:10 pm    Asunto: Responder citando Back to top

Wow yo quiero!!!!
Justo no estoy en mi casa para buscar el tutorial y ver si funciona!
De todas formas buen dato!! Asi nos motivamos y entre todos buscamos una solucion para que de resultado Wink
 
Ver perfil de usuario Enviar mensaje privado
codolar
Sobrecargo



Registrado: 06 Jul 2009
Mensajes: 259
Ubicación: Menorca LEMH - España



 MensajePublicado: Lun Nov 02, 2009 4:42 pm    Asunto: Responder citando Back to top

Hola que tal?

Si, Flauta tiene razon pero yo de "Blender" nada de nada.
La cuestion es saber si a alguien le funciona (porque a mi hasta la fecha NO) y quisiera compartir su sabiduria.
 
Ver perfil de usuario Enviar mensaje privado Enviar email
El Flauta
Ataúd Volante

Ataúd Volante


Registrado: 29 Mar 2008
Mensajes: 3975
Ubicación: SCVM, Chile



 MensajePublicado: Lun Nov 02, 2009 4:59 pm    Asunto: Responder citando Back to top

Yo creo que el modelador da un poco lo mismo. Si usas AC3D, 3DMax o Maya el tutorial te servirá, porque -según recuerdo- destinaba su parte más importante a lo que finalmente lo relacionaba con flightGear: el XML adjunto Wink

_________________


No respondo consultas por privado, ojo
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
MacDrummer
Co-piloto



Registrado: 17 Sep 2009
Mensajes: 401
Ubicación: (SCEL) Chile



 MensajePublicado: Mar Nov 03, 2009 8:13 am    Asunto: Responder citando Back to top

Listo lo logre.. era tan solo leer un poco el tutorial que está bastante simple.

Los pasos son los siguientes
1. Modelar las señales, lineas, manchas o lo que desees claramente en un plano 2D y exportarlo a AC3D (.ac) usando cualquier programa de modelado.

2.Crear el xml con esta información


<PropertyList>
<path>ElNombreDeTuModelo.ac</path>

<animation>
<type>noshadow</type>
<object-name>XXXXXXX</object-name>
</animation>

<animation>
<object-name>XXXXXXX</object-name>
<enable-hot type="bool">false</enable-hot>
</animation>

<animation>
<type>range</type>
<object-name>XXXXXXX</object-name>
<min-m>0</min-m>
<max-property>/sim/rendering/static-lod/detailed</max-property>
</animation>

</PropertyList>

Los espacios donde puse "XXXXXXX" es el nombre del plano asignado dentro del modelado de tú creación. En mi caso hice una prueba simple en Sketchup, luego exporte a 3DS para importarlo desde blender, y al hacer click con el botón derecho del mouse se selecciona el objeto y en la esqina inferior izquierda aparece el nombre que en este caso era "Model_Color_D0" (No lo modifiqué pero en las propiedades dentro del modelado puedes poner el nombre que desees pero tienes que respetarlo al ingresarlo en el XML ya que es crucial.

Los 3 modificadores son "noshadow" claramente para que no proyecte sombras, "hot-type..." para que al pasar por sobre él, las ruedas del avión no salten, y el ultimo para que se vea solo al pasar cerca y no desde lejos para no consumir tantos recursos.

3. Usar UFO para ubicar el modelo lo mas a raz de suelo posible.

4. Modificar el stg de acuerdo a lo que diga el Log de FG para localizarlo de forma definitiva (ojo que en la línea debe aparecer el modelo.xml y no .ac para que de resultado los atributos que le otorgas al objeto) de esa forma el simulador al llamar al objeto, en caso este directo el modelo.ac, no habrá ningún cambio, pero al estar el xml, FG primero pasa y lee el xml correspondiente, que le da la orden al juego de ubicar el modelo.ac (<path></path>) y sobre eso asignarle las animaciones que quieras.

5. Disfrutar

Como vi que ya lo intentaste algunas veces, omití algunos pasos que claramente ya los sabes y cualquier duda comentas para aclarar cosas en caso aun existan problemas Wink
 
Ver perfil de usuario Enviar mensaje privado
codolar
Sobrecargo



Registrado: 06 Jul 2009
Mensajes: 259
Ubicación: Menorca LEMH - España



 MensajePublicado: Mar Nov 03, 2009 10:45 am    Asunto: Responder citando Back to top

hola que tal?

De nuevo Gracias MacDrummer, me alegro de que te funcione, por mi parte lo he probado unas cuantas veces y sigue produciedose un peuqeñisimo salto de la aeronave al pasar varias veces sobre las señales.En fin.... Crying or Very sad Sad

Probare de hacer el 3D con Sketchup y exportarlo a AC3D, ya te dire que ocurre. Idea
Gracias y Saludos
 
Ver perfil de usuario Enviar mensaje privado Enviar email
El Flauta
Ataúd Volante

Ataúd Volante


Registrado: 29 Mar 2008
Mensajes: 3975
Ubicación: SCVM, Chile



 MensajePublicado: Mar Nov 03, 2009 12:55 pm    Asunto: Responder citando Back to top

Insisto... dudo que sea un problema del modelador. Lo más probable es que sea algo relativo al XML.

Un error recurrente es tener nombres diferentes en el modelo 3D y el XML, o bien saltarse algún guioncillo en las etiquetas... En fin, detallitos.

_________________


No respondo consultas por privado, ojo
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
MacDrummer
Co-piloto



Registrado: 17 Sep 2009
Mensajes: 401
Ubicación: (SCEL) Chile



 MensajePublicado: Mar Nov 03, 2009 4:08 pm    Asunto: Responder citando Back to top

Justamente codolar, asumiendo que escribes bien el XML, el único problema en tu caso debe ser que en las casillas de object name, ingresas de forma errónea el nombre del objeto que ojo, no es el nombre del archivo .ac, es el nombre de la superficie misma dentro del programa de modelado. Cuando creas un plano o una figura sea en el software que sea, le pones un nombre para identificarlo mientras modelas. Pues ese nombre es el que debes poner en el xml para que de resultado. Si no le pones nombre por defecto los programas rellenan esa información con nombres como object01, o Mesh_10, etc como ejemplo. Y algo que no está de más codolar. Fíjate muy muy bien en ponerlo con la ortografía y mayúsculas correspondientes ya que una vez no me resultó algo parecido y fue simplemente por poner el nombre del objeto con minúscula y era con mayúscula.

Mis pasos son crear el modelo en Sketchup ( ultra simple ), exportarlo a 3DS, luego importarlo en Blender en el menú de importar archivo 3DS, luego modifico su tamaño y exporto a AC3D. Reiterando para que no te pierdas en caso lo hagas como lo hice yo, al hacer click derecho en el objeto ya dentro de Blender, el nombre del plano aparecerá en la esquina inferior izquierda por ejemplo "(1) Mesh_XX_03" en ese caso no tomes en cuenta el número uno y solo ingresa desde Mesh en adelante respetando mayúsculas y minúsculas y créeme que si el resto del xml lo haces tal como lo pone el foro gringo o yo arriba, dará resultado de inmediato.

No olvides detalles simples como que el xml y el .ac tengan el mismo nombre y estén en la misma ubicación, también que lo primero que diga el xml en <path> sea el nombre del archivo ac, y que al ubicar el modelo con UFO, cargar el modelo.xml y no el modelo.ac, para que al copiar y pegar la información del log para modificar el stg, en la línea aparezca el xml que es crucial para que se apliquen las animaciones a tu objeto.

Espero te de resultado y si no nos cuentas cuales son tus problemas. Saludos Wink
 
Ver perfil de usuario Enviar mensaje privado
codolar
Sobrecargo



Registrado: 06 Jul 2009
Mensajes: 259
Ubicación: Menorca LEMH - España



 MensajePublicado: Mar Nov 10, 2009 10:03 pm    Asunto: Responder citando Back to top

hola que tal?

NADA de NADA, chicos, no hay manera de colocar señales horizontales sin que el avion efectue un pequeño salto al pisarlos Crying or Very sad Crying or Very sad
Y eso que tengo en cuenta todos los detalles que comentais tanto a nivel nombre en el 3D como en el archivo .xml, de todas maneras gracias por vuestra ayuda y ..... seguire intentandolo.... Smile

Saludos
 
Ver perfil de usuario Enviar mensaje privado Enviar email
MacDrummer
Co-piloto



Registrado: 17 Sep 2009
Mensajes: 401
Ubicación: (SCEL) Chile



 MensajePublicado: Mie Nov 11, 2009 12:34 am    Asunto: Re: Responder citando Back to top

codolar escribió:
hola que tal?

NADA de NADA, chicos, no hay manera de colocar señales horizontales sin que el avion efectue un pequeño salto al pisarlos Crying or Very sad Crying or Very sad
Y eso que tengo en cuenta todos los detalles que comentais tanto a nivel nombre en el 3D como en el archivo .xml, de todas maneras gracias por vuestra ayuda y ..... seguire intentandolo.... Smile

Saludos


comparte el modelo ".ac" que creaste y veré si corrijo tu xml para que te funcione...
Espero el link Wink
 
Ver perfil de usuario Enviar mensaje privado
Mostrar mensajes de anteriores:   
Publicar nuevo tema   Responder al tema    Foros de discusión -> Dudas Todas las horas son GMT + 1 Hora
Página 1 de 1


 
Cambiar a:  
Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro







Crear foro | foros de Videoconsolas | Free forum | soporte foros | Contactar | Denunciar un abuso | FAQ | Foro ejemplo