Vive FG! (Foro) Vive FG! (Foro)
Foro de la comunidad hispana oficial del simulador de código abierto FlightGear Flight Simulator.






Y [ya no] me quedé con las ganas de compilar y probar el 2.0

 
Publicar nuevo tema   Responder al tema    Foros de discusión
Ver tema anterior :: Ver tema siguiente  
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Mie Jun 23, 2010 9:01 am    Asunto: Y [ya no] me quedé con las ganas de compilar y probar el 2.0 Responder citando Back to top

b.

Hasta ahora vengo manejando la versión 1.9.1 de los repositorios oficiales de ubuntu, pero se me ocurrió Mr. Green (por aquello de estar de vacaciones y con algo de tiempo libre), que por qué no bajarme el paquete y compilarlo. Así que tras ir cumpliendo con todas las cosicas que me iba diciendo el quisquilloso .configure llego al punto en que ¡me farta Embarassed el simgear 2.0! (en los repositorios sigue el 1.9.1). Y Shocked que el www.simgear.org está fuera de servicio Aviador y eso ya ha podido conmigo, esnif.

Saludos cordiales

 
Ver perfil de usuario Enviar mensaje privado
El Flauta
Ataúd Volante

Ataúd Volante


Registrado: 29 Mar 2008
Mensajes: 3975
Ubicación: SCVM, Chile



 MensajePublicado: Mie Jun 23, 2010 3:33 pm    Asunto: Responder citando Back to top

¿Y probaste el "Brisa script" del que se habla en el foro y la wiki oficial? Dicen que está actualizado a la versión 2 y repositorio GITs.

(Como sea, en mi vida intenté siquiera utilizar SimGear, por la mala documentación) Embarassed

_________________


No respondo consultas por privado, ojo
 
Ver perfil de usuario Enviar mensaje privado Visitar sitio web del autor
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Mie Jun 23, 2010 7:02 pm    Asunto: Re: Responder citando Back to top

El Flauta escribió:
¿Y probaste el "Brisa script" del que se habla en el foro y la wiki oficial? Dicen que está actualizado a la versión 2 y repositorio GITs.

(Como sea, en mi vida intenté siquiera utilizar SimGear, por la mala documentación) Embarassed


b., ¡muchas gracias por el apunte!, con poner "brisa script" en la búsqueda he localizado el tema en un pispás (http://www.flightgear.org/forums/viewtopic.php?f=20&t=7946&st=0&sk=t&sd=a&hilit=brisa+script#p77442) y un mirror para el código de simgear jeje, así que esta noche lo mismo ya puedo tenerlo rulando Cool

Saludos cordiales
 
Ver perfil de usuario Enviar mensaje privado
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Mie Jun 23, 2010 9:10 pm    Asunto: Responder citando Back to top

b., bueno, pos no! Me siguen faltando más librerías, aunque el .configure no me avisara de ello (por ejemplo zlib, alguna otra que me falta por localizar). Lo que sí he podido es descargarme los .deb y echarle un vistazo a FG 2.0, pero ya que tenemos aquí el código pues eso, a ver si puedo compilarlo...

Saludos cordiales

Edito:

b., oops parece que una cosa es el 'make chek" y otra muy distinta el "make' de verdad Very Happy . O puede que tuviera que abrir otra consola para que se actualizaran las variables de entorno (no sé hasta qué punto se actualizan en ejecución, creo que sí). El caso es que ¡ya ta! Very Happy Parece que se nota bastante más fluido al compilarlo "en casa", así que creo que voy a mudarme al 2.0 ya mismo. Gracias por la ayuda.

Saludos cordiales
 
Ver perfil de usuario Enviar mensaje privado
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Vie Jun 25, 2010 10:33 am    Asunto: Peripecias de la compilación en ubuntu lucid... Responder citando Back to top

b.,

¡Menos mal que estoy de vacaciones! Lo cierto es que compilar el programa me merece la pena para aprovechar los recursos del procesador (de modo que va un poco más desahogado y no se calienta tanto), pero ¡ay madre! La verdad es que es bastante lioso. Por ejemplo las utilidades como FGrun/Atlas/FGcom están preparadas para la versión 1.9.1 de SimGear, pero FlightGear necesita necesariamente la última versión -o equivalente-, así que el famoso "brisa script" hay que utilizarlo con cuidado: personalmente he preferido hacer las cosas a mano, aunque las órdenes las sacara de ahí. Y hay que ingeniárselas para que cada cosa vea la versión del SimGear que necesita (por ejemplo, renombrando el usr/local/lib y el usr/local/include/simgear "desaparece" el simgear 2 que hayamos compilado nosotros), de lo contrario nos salen un montón de errores de compilación.

Con todo, la versión 2.0.1 (o casi) falla en algunas cosicas (el sonido, por ejemplo, aún no está fino; y el ATC sigue fuera de servicio), así que he recuperado el paquete del 1.9.1 y lo he conseguido compilar. Creo que como siga de vacaciones acabaré haciendo un 1.9.2 o algo similar Very Happy .

Por cierto, la versión del FGrun que me he bajado de appfgcom.svn.sourceforge.net tiene unos locales en español horribles, creo que merece la pena borrar la traducción y quedarse con el inglés... El FGo es más sencillo, pero al menos está bien escrito Smile.

Saludos cordiales
 
Ver perfil de usuario Enviar mensaje privado
NiTuS
Administrador



Registrado: 01 Jun 2007
Mensajes: 2259
Ubicación: Reus, España (LERS)



 MensajePublicado: Vie Jun 25, 2010 3:30 pm    Asunto: Responder citando Back to top

Menos mal que Flauta me recomendó que no me atreviera a compilar FlightGear 2.0.0... Mr. Green

almursi escribió:
Por cierto, la versión del FGrun que me he bajado de appfgcom.svn.sourceforge.net tiene unos locales en español horribles, creo que merece la pena borrar la traducción y quedarse con el inglés...


Probablemente se trate de la primera traducción que hicimos para FlightGear, que era muy literal. En la versión estable 2.0.0 para Windows hay una versión posterior, algo mejor que la otra.
 
Ver perfil de usuario Enviar mensaje privado Enviar email Visitar sitio web del autor
almursi
Sobrecargo



Registrado: 21 Jun 2010
Mensajes: 318
Ubicación: LELC Murcia (Spain)



 MensajePublicado: Vie Jun 25, 2010 9:48 pm    Asunto: Re: Responder citando Back to top

NiTuS escribió:
Probablemente se trate de la primera traducción que hicimos para FlightGear, que era muy literal. En la versión estable 2.0.0 para Windows hay una versión posterior, algo mejor que la otra.


b., ¡es verdad, que allí andás! jeje.

Este es el "timestamp" del es.po:

Código:
POT-Creation-Date: 2010-04-11 16:23+0200


En linux no aparecen correctamente los acentos (la configuración en "CP1252" es una reliquia de los primeros güindos, así que trae cuenta usar el UTF-8). Y en la ventana de diálogo se escapan bastantes líneas que no caben (al estar ajustado al tamaño del texto en inglés). Si tienes una versión más reciente puedes pasármela y la pulimos para que funcione bien en ubuntu Mr. Green (he hecho una primera revisión, pero me quedé a la mitad cuando comenzó el partido...).

Saludos cordiales
 
Ver perfil de usuario Enviar mensaje privado
Mostrar mensajes de anteriores:   
Publicar nuevo tema   Responder al tema    Foros de discusión -> Paraíso Linux Todas las horas son GMT + 1 Hora
Página 1 de 1


 
Cambiar a:  
Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro


Crear un foro gratis | foros de Videoconsolas | Hosting gratis | soporte foros | Contactar | Denunciar un abuso | FAQ | Foro ejemplo

Para vps hosting especialidado en foros phpbb ssd en Desafiohosting.com